Wordpress 5. Nueva versión de Wordpress con editor Gutenberg
Diciembre 2018
  • Diseño web

Wordpress 5 ya está aquí, y con él, su nuevo editor de páginas Gutenberg, basado en bloques. Esta nueva versión supone un gran cambio en la forma en la que se crea el contenido, ya que gracias a Gutenberg, habrá más flexibilidad en la forma en la que se crean o editan los contenidos del sitio web.

Normalmente, una nueva versión de Wordpress supone algunas mejoras, corrección de error e incluso alguna funcionalidad nueva, por lo que tener el sitio actualizado es una buena praxis, para una página web profesional a pleno rendimiento. Pero esta nueva versión requiere plantearse unas cuantas cosas, antes de dar el paso a actualizar.

Esta guía intentará ayudarte a la hora de decidir actualizar a la nueva versión. Si tienes cualquier duda, no dudes en contactar con nosotros.

Índice de contenidos

  1. Novedades de Wordpress 5
  2. ¿Debo actualizar a la nueva versión?
  3. ¿Por qué esperar y hacer la actualización más adelante?
  4. ¿Puedo seguir utilizando el antiguo editor?
  5. Conclusión

1. Novedades de Wordpress 5

La gran novedad, es la forma en la que Wordpress se reinventa con un diseño orientado a la escritura y creación de contenidos con aún más facilidad, aunque también cuenta con otras mejoras como:

  • Nuevo theme. Plantilla Twenty Nineteen compatible con el nuevo editor.
  • Mejoras de seguridad
  • Rest API mejorada
  • Compatibilidad con PHP 7.3.
  • Mejoras responsive
  • Compatibilidad con PHP 7.3.

En el siguiente vídeo se muestra el funcionamiento del nuevo editor:

Un nuevo concepto de diseño basado en bloques:

Diseño basado en bloques

2. ¿Debo actualizar a la nueva versión?

En ningún caso sin antes probar que todo funciona correctamente.

Si tienes un subdominio o servidor de pruebas, debes comprobar que todo funciona correctamente, antes de actualizar tu web en producción.

Existen algunos plugins que pueden ser no compatibles con la nueva versión, por lo que pon especial atención, si usas plugins como:

  • WPML. El traductor de Wordpress que ha anunciado que recomienda posponer la actualización.
  • WP Backery Page Builder (o Visual Composer). Ya que tendrán que actualizar la compatibilidad con su nuevo editor.
  • Yoast SEO. Que en recomiendan no actualizar todavía si no se tiene una razón de peso.
  • ACF (Advanced Custom Fields). Una herramienta que también sudará, para hacerse hueco junto con el nuevo editor, tal y como nos cuentan en su web.
  • Woocommerce. Esto es delicado, como mínimo deberás tener la versión 3.51., y probar todos los plugins o funcionalidades relacionadas con la Tienda online Woocommerce

Respecto a la plantilla o theme que estemos utilizando, es posible que use plugins como WP Bakery, por lo que será el propio autor de la plantilla el que deba determinar qué versión es compatible con Wordpress 5.

3. ¿Por qué esperar y hacer la actualización más adelante?

Un sitio web Wordpress se basa en el núcleo o la herramienta base del gestor de contenido, plantilla y plugins instalados.

El primer paso ya se ha dado, Wordpress 5 ha nacido, pero dependiendo de la empresa o autores de los diferentes plugins, tardarán más o menos en actualizar sus funcionalidades a esta nueva forma de edición.

Si ansías tener las nuevas funcionalidades de Wordpress 5, o crees que va a suponer una ventaja para tu proyecto, sí que cabe plantearse actualizar y que tu web sea una de las pioneras en esta aventura.

Si por el contrario puedes prescindir de momento de estas novedades, el camino necesario hacia la nueva versión será más fácil, cuando se haya dejando un tiempo para la corrección de errores y mejoras en la compatibilidad con el nuevo editor.

4. ¿Puedo seguir utilizando el antiguo editor?

Sin problema, Wordpress asegura que seguirá siendo compatible con el antiguo editor hasta 2021. Por lo que puedes seguir funcionando como hasta ahora y retrasar el cambio un tiempo.

El plugin "Classic Editor" restaura el editor anterior de WordPress 4. Para instalarlo, visita la página de plugins y haz clic en el botón "Instalar ahora" al lado de "Classic Editor". Después de que el plugin termine de instalarse, haz clic en "Activar".

Comparativa de editores Wordpress 5

5. Conclusión

Wordpress ha cambiado, la forma en la que se crean los contenidos ha cambiado y habrá que adaptarse a los cambios. Esta puede ser una buena excusa para renovar o rehacer tu sitio web de forma mejorada, en cuyo caso, deberás utilizar (como siempre), plantillas y plugins compatibles con la versión de Wordpress.

Si se trata de una actualización, mejor si puedes esperar y si no comprueba que todo funciona correctamente antes de actualizar tu sitio en producción.

No dudes en contactar con nosotros si tienes cualquier duda.